みどりとくらす

バラとランと多肉と観葉植物と・・・

【PHP】Xserver、PHP7 適用を推奨!しかし、本ブログで PHP7 は NG

本ブログは「レンタルサーバー Xserver」を利用して運用しています。個人的には、かなりのお気に入りで、それこそ沢山のドメインを管理しています(マルチドメインがカバーされている!)。WordPress は「自動インストール」という機能があって、それこそワンクリックでインストールが完了できるのも素晴らしい!

そんな「Xserver」からお知らせが届きました!

この度エックスサーバーでは、推奨するPHPバージョンを「7.0」に変更いたします。引き続きPHP 5.6 もご利用いただけますが、今後はPHP 7.0 のご利用を推奨いたします。

また、新規に追加設定されるドメインにおいて、初期状態でご利用いただけるPHPのバージョンを「7.0」に変更いたします。出典:「推奨PHPバージョン変更のお知らせ – 2017/02/13 | レンタルサーバー【エックスサーバー】」より

そこで、早速個人で利用している「テストサイト」に PHP7 を適用してみましたが・・・残念ながら「Exec-PHP」というプラグインでエラーが発生してしまいます。他のプラグインでは、正常に機能するのですが・・・

本ブログでは「Exec-PHP」は重要なプラグインで、このプラグインを外すと、色々なページを修正する必要があるため、考えに考えて・・・PHP7 の適用を今回は見送ることにしました・・・最新版にこだわっている私にとっては、かなりショックです・・・

今後、PHP7 で「Exec-PHP」が機能するように祈っています。

更新日: 2017年02月14日 — 12:36 AM

気楽にコメントして頂けますように!コメントは承認後の公開です。

(必須) スパム対策にご協力下さい。下記、数式を完成してコメント送信して下さい。

Copyright © 2016-2017 by Zero Cool. All rights researved. Frontier Theme